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 Important Information

Warranty
The RT Series PXI/CompactPCI Contoller is warranted against defects in materials and workmanship for a period of one year from 
the date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace 
equipment that proves to be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, 
due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other 
documentation. National Instruments will, at its option, repair or replace software media that do not execute programming 
instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not 
warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of 
the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of 
returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed 
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to 
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult 
National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages arising out of 
or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY 
WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR 
NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL  
INSTRUMENTS WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will 
apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments 
must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in 
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, 
malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or 
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or 
surges, fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including 
photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written 
consent of National Instruments Corporation.

Trademarks
LabVIEW™, National Instruments™, ni.com™, NI-DAQ™, and PXI™ are trademarks of National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL 
OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL 
COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE 
EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS 
CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL 
POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE 
FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, 
INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR 
FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC 
SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF 
THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER 
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD 
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) 
SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM 
FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE 
REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO 
BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS 
FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER 
MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT 
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS 
ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL 
INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A 
SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND 
SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



© National Instruments Corporation v RT Series PXI/CompactPCI Controller User Manual

Contents

About This Manual
Conventions ...................................................................................................................vii
Related Documentation..................................................................................................viii

Chapter 1
Introduction

About RT Series PXI Controller....................................................................................1-1
What You Need to Get Started ......................................................................................1-2
Software Programming Choices ....................................................................................1-2

Chapter 2
Installation and Configuration

Remote System Explorer Installation ............................................................................2-1
Network Configuration ..................................................................................................2-1

PXI Controller on Network .............................................................................2-1
Direct CAT-5 Crossover Cable Connection....................................................2-2

Booting into LabVIEW RT............................................................................................2-2
PXI Controller with LabVIEW RT Installed...................................................2-2
PXI Controller with Windows Installed ..........................................................2-2

Configuration .................................................................................................................2-4
Using Remote System Explorer ......................................................................2-4
Configuring your RT Series PXI System Using Toolbar Functions ...............2-5
Disk Utilities....................................................................................................2-5

PXI Format Hard Drive Disk ............................................................2-6
PXI Uninstall Disk ............................................................................2-6
PXI Boot Disk...................................................................................2-6
PXI Launch Settings Reset Disk.......................................................2-6
PXI IP Settings Reset Disk ...............................................................2-6

IP Address Configuration................................................................................2-7
Ethernet Parameters.........................................................................................2-9
Choosing an IP Address ..................................................................................2-10

For a Network Administered by a Network Administrator ..............2-10
For a Network Without a Network Administrator ............................2-10

Software Installation........................................................................................2-11
Locking System Configuration........................................................................2-13
Remote DAQ Configuration............................................................................2-14



Contents

RT Series PXI/CompactPCI Controller User Manual vi www.ni.com

Chapter 3
LabVIEW RT Programming

Launching LabVIEW RT and Downloading VIs.......................................................... 3-1
Network Preferences ..................................................................................................... 3-2

RT Target: Access........................................................................................... 3-2
RT Target: Miscellaneous............................................................................... 3-5

Creating Stand-Alone Executables................................................................................ 3-6
Command Line Arguments............................................................................. 3-6
Embedded Applications .................................................................................. 3-7

Programming LabVIEW RT ......................................................................................... 3-8

Appendix A
Troubleshooting

Remote System Explorer Cannot Find PXI Controller ................................................. A-1
PXI Controller Boots into Windows When a LabVIEW RT

Boot Floppy Disk is Used........................................................................................... A-1
Runaway Startup Application........................................................................................ A-2

Appendix B
Technical Support Resources

Glossary

Index



Contents

© National Instruments Corporation vii RT Series PXI/CompactPCI Controller User Manual

Figures
Figure 2-1. Remote System Explorer.......................................................................2-3
Figure 2-2. PXI Boot Disk Dialog Box....................................................................2-3
Figure 2-3. System Configuration Dialog Box ........................................................2-7
Figure 2-4. IP Stack Tab ..........................................................................................2-8
Figure 2-5. Updated Remote System Explorer ........................................................2-9
Figure 2-6. Currently Installed Software Dialog Box..............................................2-12
Figure 2-7. Install/Upgrade Software Dialog Box ...................................................2-13

Figure 3-1. Select Target Platform Dialog Box .......................................................3-1
Figure 3-2. RT Target: Access Preferences Dialog Box..........................................3-3
Figure 3-3. RT Target: Miscellaneous Preferences Dialog Box ..............................3-5
Figure 3-4. Build Application Dialog Box...............................................................3-7

Table
Table 3-1. Example RT Target: Access List Entries ..............................................3-4



© National Instruments Corporation ix RT Series PXI/CompactPCI Controller User Manual

About This Manual

This manual contains information about the RT Series PXI/CompactPCI 
controller and working with LabVIEW RT. You can use LabVIEW RT and 
NI-DAQ to create embedded, real-time applications that run on the 
PXI-8156B controller.

Conventions
The following conventions appear in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represent a 
range of values associated with a bit or signal name—for example, 
DBIO<3..0>.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click on in the software, 
such as menu items and dialog box options. Bold text also denotes 
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.
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Related Documentation
The following documents contain information that you might find helpful 
as you read this manual:

• LabVIEW RT User Manual

• LabVIEW RT Release Notes

• LabVIEW RT Help, available by selecting Help»LabVIEW RT Help

• PXI-8150B Series User Manual

• LabVIEW QuickStart Guide

• LabVIEW User Manual

• G Programming Reference Manual

• LabVIEW Online Reference, available by selecting 
Help»Online Reference

• LabVIEW Application Builder Release Notes
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1
Introduction

This chapter introduces the RT Series PXI/CompactPCI controller and lists 
what you need to begin working with LabVIEW RT and your PXI 
controller.

About RT Series PXI Controller
You can use LabVIEW RT with any National Instruments PXI system with 
a PXI-8156B controller, providing an easy-to-use system for real-time 
applications. When you run LabVIEW RT on a PXI controller, the PXI 
system acts as a headless system. You can run applications on the system 
without input from the keyboard or mouse. Instead, you use a separate 
host PC or PXI system running Windows to control the RT Series 
PXI system through an Ethernet connection. When used in this manner, the 
microprocessor on the PXI controller runs real-time, embedded LabVIEW 
RT applications.

Note You can use any National Instruments PXI-8156B controller with LabVIEW RT. 
This manual uses RT Series PXI controller only to refer to a controller that is running 
LabVIEW RT as opposed to running Windows or another operating system.

When using a LabVIEW RT Series PXI system, you can write applications 
that use all the I/O capability of any National Instruments PXI data 
acquisition (DAQ) boards installed in the system, and SCXI, signal 
conditioning, and so on. You also can use the GPIB and serial ports onboard 
the PXI controller for instrument control in LabVIEW RT applications.

You must use a separate host PC or PXI system running Windows to install 
and configure LabVIEW RT on the real-time PXI controller. You also use 
the host PC or PXI system to develop and launch LabVIEW RT 
applications on the real-time PXI controller.
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What You Need to Get Started
To set up and use LabVIEW RT with your PXI controller, you need the 
following:

❑ PXI chassis with PXI-8156B controller and a floppy disk if 
LabVIEW RT is not pre-installed

❑ LabVIEW RT User Manual

❑ This manual

❑ A host PC or PXI system

❑ LabVIEW RT

❑ NI-DAQ

❑ A CAT-5 crossover cable if the PXI-8156B controller is not configured 
on a network

Software Programming Choices
You can use the PXI-8156B controller with LabVIEW RT and NI-DAQ. 
NI-DAQ is included with LabVIEW RT and can be installed during the 
LabVIEW RT installation. Refer to the LabVIEW RT Release Notes for 
more information about LabVIEW RT and NI-DAQ version compatibility. 
Refer to Chapter 2, Installation and Configuration, for instructions on 
installation of your RT Series hardware and software.
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2
Installation and Configuration

This chapter explains how to install and configure LabVIEW RT on your 
PXI controller.

Note Install LabVIEW RT, NI-DAQ, and Remote System Explorer on the host PC or PXI 
system before you configure your PXI controller. Refer to Chapter 2, Installation, of the 
LabVIEW RT User Manual for more information about installing LabVIEW RT and 
NI-DAQ.

Remote System Explorer Installation
Complete the following steps to install Remote System Explorer on the 
host PC or PXI system.

1. If you are not installing Remote System Explorer on Windows NT, 
proceed to step 2. If you are installing Remote System Explorer on 
Windows NT, log on to Windows NT as an administrator or as a user 
with administrator privileges.

2. Insert the LabVIEW RT CD into your CD drive. The LabVIEW RT 
installation program runs automatically.

3. Click Install Remote System Explorer. Follow the instructions that 
appear on your screen.

Network Configuration
The host PC or PXI system communicates to the RT Series PXI controller 
over a standard Ethernet connection. If the host PC or PXI system is already 
configured on a network, you must configure your RT Series PXI controller 
on the same network. If neither machine is connected to a network, you 
must connect the two machines directly using a CAT-5 crossover cable.

PXI Controller on Network
If the host PC or PXI system and the RT Series PXI controller are 
configured on a network, both must reside on the same subnet. Contact 
your network administrator if you need assistance configuring your host PC 
and RT Series PXI system on the same subnet.
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You can develop and run LabVIEW RT applications when the RT Series 
PXI controller is on a different subnet than that of the host PC. For example, 
you might need to use the RT Series PXI system remotely. In this case you 
must first configure the RT Series PXI controller on the same subnet as 
the host PC. You must assign a static IP address to the controller that 
corresponds to the subnet where the RT Series PXI controller will be 
located. Refer to the Ethernet Parameters section later in this chapter for 
more information about IP addresses.

Direct CAT-5 Crossover Cable Connection
If the host PC is not configured on a network, you must connect the 
RT Series PXI controller to the host using a CAT-5 crossover cable. 
This provides a direct connection that allows you to configure the RT 
Series PXI controller from the host PC or PXI system.

Booting into LabVIEW RT
The method of booting the PXI system into LabVIEW RT depends on the 
type of PXI system you have. Some PXI systems have LabVIEW RT 
pre-installed on the hard drive of the PXI controller. However, you can use 
a boot floppy disk to boot into LabVIEW RT on a PXI system with 
Windows installed.

PXI Controller with LabVIEW RT Installed
You can order PXI controllers from National Instruments with 
LabVIEW RT pre-installed in the appropriate location on the hard drive. 
Simply turn on the PXI system to boot into LabVIEW RT. Refer to the 
Configuration section later in this chapter for more information about 
configuring your PXI system.

PXI Controller with Windows Installed
You also can order PXI controllers from National Instruments with 
Windows installed. To boot into LabVIEW RT, you must boot the 
PXI controller with a PXI Boot Disk in the floppy disk drive.

Complete the following steps to create a boot disk from your host PC or 
PXI system:

1. Place a floppy disk in the drive of the host PC. Note that any data on 
the floppy disk will be overwritten.
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2. Select Programs»National Instruments LabVIEW»Remote 
System Explorer from the Windows Start menu on the host PC. 
Remote System Explorer, shown in Figure 2-1, appears.

Figure 2-1.  Remote System Explorer

3. Select Disks»Create PXI Boot Disk.

4. The PXI Boot Disk dialog box appears as shown in Figure 2-2. Click 
Yes to make the boot disk. Follow the instructions that appear on your 
screen.

Figure 2-2.  PXI Boot Disk Dialog Box

5. When you finish creating the boot disk, remove the floppy disk and 
label it “LabVIEW RT PXI Boot Disk.”

Use this boot disk each time you boot your Windows PXI controller into 
LabVIEW RT. Insert the boot disk into the floppy drive of your PXI 
controller you will use as the RT Series PXI controller. Power on or reset 
the controller to boot into LabVIEW RT. You can now configure your 
RT Series PXI controller. Refer to the Configuration section later in this 
chapter for more information about configuring your PXI controller.
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The boot sequence for your PXI controller defined in the BIOS settings 
must be set to A,C,… to boot from a floppy disk. If this BIOS setting is set 
to boot from the C:  drive before the A:  drive, the controller boots into 
Windows. Refer to your PXI-8150B Series User Manual for more 
information about BIOS settings. In addition, you might need to change 
your BIOS settings if you are booting your PXI controller without a 
keyboard. Refer to Appendix A, Troubleshooting, for more information 
about using BIOS settings to boot the controller without a keyboard 
connected.

Configuration
Before you begin using LabVIEW RT with your RT Series PXI controller, 
you need to configure the IP address of the controller using Remote System 
Explorer. You also need to install LabVIEW RT software on the PXI 
controller if you did not order the controller with LabVIEW RT 
preinstalled. In addition, you need to configure any DAQ boards installed 
in the RT Series PXI system. Refer to the Remote DAQ Configuration 
section later in this chapter for more information about configuring DAQ 
boards installed in your RT Series PXI system.

Using Remote System Explorer
Select Programs»National Instruments LabVIEW»Remote System 
Explorer  from the Windows Start menu on the host PC. When Remote 
System Explorer launches, there is a short delay while it searches for any 
RT Series PXI systems on the subnet. All systems found appear in the 
window of Remote System Explorer. If only one RT Series PXI system is 
found, Remote System Explorer appears as shown in Figure 2-1.

The serial number for the device shown corresponds to the serial number of 
your PXI controller. The status of the system is Unconfigured  because 
you have not yet set the IP address for the RT Series PXI controller. If more 
than one system appears in Remote System Explorer, click the serial 
number of the system you want to configure.
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Configuring your RT Series PXI System Using Toolbar Functions
Use the Remote System Explorer toolbar buttons to configure your RT 
Series PXI system. The toolbar contains the following functions:

• Configure System—Use to configure the IP address, comment, and 
other parameters for the selected PXI system. Refer to the IP Address 
Configuration section later in this chapter for more information about 
IP addresses.

• Install/Upgrade Software—Use to install or upgrade LabVIEW RT 
software on the selected PXI controller. Refer to the Software 
Installation section later in this chapter for more information about 
installing or upgrading LabVIEW RT.

• Reboot System—Use to reboot the selected PXI controller.

• View Installed Software—Use to view the LabVIEW RT and driver 
software versions installed on the selected PXI controller.

• Lock/Unlock System—Use to lock or unlock the system 
configuration with a password.

• Large icon view—Changes the view in the main window to large 
icons.

• Small icon view—Changes the view in the main window to small 
icons.

• List view—Changes the view in the main window to a list.

• Detailed view—Changes the view in the main window to a list with 
additional information such as serial number, IP address, status, 
model, and comment.

• Refresh Browse List—Use to refresh the list of PXI systems found on 
the local subnet or at the specified IP address. Changes to IP address, 
comment, and so on do not appear in Remote System Explorer until 
you reboot the selected system and click the Refresh Browse List 
button.

• System Location—Use to change the search location for PXI systems 
to the local subnet or to a specific IP address.

Disk Utilities
Use the Disks menu in Remote System Explorer to create floppy disks for 
your RT Series PXI system. You can create the following disks:

• PXI Format Hard Drive Disk

• PXI Uninstall Disk

• PXI Boot Disk
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• PXI Launch Settings Reset Disk

• PXI IP Settings Reset Disk

PXI Format Hard Drive Disk
The PXI Format Hard Drive Disk reformats the C:  drive of the RT Series 
PXI controller, deleting all data on that system. It then configures the hard 
disk to boot directly into the real-time operating system. This allows you to 
boot into LabVIEW RT if LabVIEW RT was not preinstalled. All other 
operating systems and data will be deleted.

If you want the ability to boot your PXI system into either Windows 
or LabVIEW RT, use a PXI Boot Disk each time you want to boot 
into LabVIEW RT. If you prefer to use your PXI system only for real-time 
LabVIEW RT applications, use the PXI Format Hard Drive Disk once to 
enable the system to boot into LabVIEW RT without a boot floppy.

PXI Uninstall Disk
The PXI Uninstall Disk removes an installation of LabVIEW RT, along 
with all configuration information, such as IP Address, and so on. This 
allows you to reinstall the software if the system becomes unresponsive and 
prevents you from installing software remotely.

PXI Boot Disk
The PXI Boot Disk boots the PXI controller into LabVIEW RT. You must 
have this disk in the PXI controller floppy drive to boot into LabVIEW RT.

PXI Launch Settings Reset Disk
The PXI Launch Settings Reset Disk resets the system so that LabVIEW 
RT does not start any user applications upon boot up. No other settings are 
affected. Use this disk if a runaway user application has caused the system 
to become unresponsive. Refer to the Creating Stand-Alone Executables 
section in Chapter 3, LabVIEW RT Programming, for more information 
about user applications.

PXI IP Settings Reset Disk
The PXI IP Settings Reset Disk resets the IP network settings of the PXI 
machine to the factory defaults, 0.0.0.0 . You also can use this disk to 
clear the password and unlock the PXI system if the system is locked with 
a password.
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IP Address Configuration
Complete the following steps to configure the IP address of your RT Series 
PXI controller using Remote System Explorer:

1. Select Programs»National Instruments LabVIEW»Remote 
System Explorer from the Windows Start menu on your host PC to 
run Remote System Explorer.

2. Click on your PXI system and select Tools»Configure System to 
begin configuration. You are then warned that the system is currently 
unlocked. Click OK . The System Configuration dialog box, as shown 
in Figure 2-3, appears.

Figure 2-3.  System Configuration Dialog Box

Note You can invoke the Configure System, Install/Upgrade Software, Reboot 
System, View Installed Software, and Lock/Unlock System dialog boxes from either the 
Tools menu or the toolbar in Remote System Explorer. You also can select these actions 
by right-clicking on the serial number of any remote system listed in Remote System 
Explorer.

3. Enter a host name in the Host Name field. The file system uses the host 
name to identify your computer. Enter a comment in the Comment 
field to help you identify your RT Series PXI system.

4. Click the Password-protect Resets checkbox to allow the user to 
reboot the system remotely only when the user provides the password.
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5. Select the IP Stack tab in the System Configuration dialog box. 
The IP Stack Tab, as shown in Figure 2-4, appears. Enter the Ethernet 
parameters you will assign to the PXI controller. Refer to the Ethernet 
Parameters section later in this chapter for more information about 
each of the Ethernet parameters.

Figure 2-4.  IP Stack Tab

6. Click the Halt system if TCP/IP fails checkbox to stop LabVIEW RT 
if the network connection fails when you boot the PXI system. If you 
clear the Halt system if TCP/IP fails checkbox, LabVIEW RT starts 
and runs startup applications you created, even if TCP/IP fails when 
you boot the system.

7. Click OK  in the System Configuration dialog box. Click Yes when 
prompted to reboot the RT Series PXI controller. After the RT Series 
PXI controller has rebooted, select View»Refresh to view the updated 
Remote System Explorer with the updated IP address and comment, as 
shown in Figure 2-5.
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Figure 2-5.  Updated Remote System Explorer

Ethernet Parameters
You must either click the Obtain IP Address from DHCP Server 
checkbox in the IP Stack tab of the System Configuration dialog box 
or provide the RT Series PXI controller with several important network 
parameters. If your RT Series PXI system is on a network that has a 
Dynamic Host Configuration Protocol (DHCP) server, you can use the 
Obtain IP Address from DHCP Server option. A DHCP server allocates 
an IP address to your PXI controller each time the PXI controller is booted. 
You do not need to specify other information such as IP Address if you 
select the DHCP Server option. If you do not know whether your network 
has a DHCP server, check with your network administrator for assistance.

Not all DHCP servers are implemented in the same manner. Therefore, 
some might not be compatible with LabVIEW RT. Once you select Obtain 
IP Address from DHCP Server and reboot the PXI controller, LabVIEW 
RT tries to obtain an IP address from the DHCP server. If this operation 
fails, LabVIEW RT automatically reboots the controller and makes a 
second attempt. After three failed attempts, LabVIEW RT returns to the 
default configuration with IP address 0.0.0.0 . In this case, you need to 
explicitly specify the network parameters.

Note When you use a DHCP server, the server allocates a new IP address to the RT Series 
PXI controller each time you boot the controller. The new IP address might be different 
than the address previously assigned. If you use the DHCP server to assign an IP address 
to your PXI controller, you need to check the IP address using Remote System Explorer 
each time you target LabVIEW RT to the PXI system. To avoid needing to check the 
IP address each time, specify a static IP address for the PXI controller instead of using 
a DHCP server.
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If you clear the Obtain IP Address from DHCP Server checkbox, you 
must specify the following network parameters in the IP Stack tab of the 
System Configuration dialog box.

• IP Address—The unique, computer-readable address of a device on 
your network. An IP address is typically represented as four numbers 
separated by periods (for example, 127.165.55.112 ). Refer to the 
Choosing an IP Address section later in this chapter for more 
information about choosing an IP address.

• Subnet Mask—A code that helps the network device determine 
whether another device is on the same network or a different network. 
255.255.255.0  is the most common subnet mask.

• Gateway—The IP address of a device that acts as a gateway server, 
which is a connection between two networks.

• DNS Address—The IP address of a network device that stores host 
names and translates them into IP addresses.

IP Address and Subnet Mask are required parameters. If your network 
does not have a gateway server or DNS server, set these parameters to the 
default configuration, 0.0.0.0 .

Choosing an IP Address
If you specify the network parameters for the RT Series PXI controller 
without using the Obtain IP Address from DHCP Server option in the 
IP Stack tab of the System Configuration dialog box, you must choose an 
IP address for your networked PXI controller.

For a Network Administered by a Network 
Administrator
If you are adding the RT Series PXI system to an existing Ethernet network, 
you must choose IP addresses carefully to avoid conflicts. Consult with 
your network administrator to obtain an IP address. Ask your administrator 
to assign a static IP address to your RT Series PXI controller. Also request 
the proper subnet mask, gateway, and DNS server addresses from your 
network administrator.

For a Network Without a Network Administrator
If you are assembling your own small Ethernet network, you can choose 
your own IP addresses. The subnet mask determines the format of the 
IP addresses. Use the same subnet mask as the host PC when you configure 
your RT Series PXI controller. If your subnet mask is 255.255.255.0 , 
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the first three numbers in every IP address on the network must be the same. 
If your subnet mask is 255.255.0.0 , only the first two numbers in the 
IP addresses on the network must match. 

For either subnet mask, you can use numbers between 1 and 254 for the last 
number of the IP address. You can use numbers between 0 and 255 for the 
third number of the IP address, but this number must be the same as other 
devices on your network if your subnet mask is 255.255.255.0 .

If you are setting up your own network, you probably do not have a gateway 
or DNS server, so set these values to the default configuration, 0.0.0.0 . 

To find out the network settings for your host PC, run winipcfg on 
Windows 98/95 or ipconfig on Windows NT/2000. To run winipcfg, select 
Run from the Windows Start menu. Type winipcfg  in the Open field, and 
click OK . The IP Configuration  dialog box appears, which gives you 
information about the network setup for your computer. Verify that you 
have selected the Ethernet adapter that is connected to the network from the 
pull-down menu at the top of the dialog box. Most computers have only one 
Ethernet card, but many are configured for dial-up networking such as PPP 
or SLIP. Make sure you view the settings for the Ethernet adapter, not for 
dial-up networking.

To run ipconfig on Windows NT/2000, open a Command Prompt window, 
type ipconfig  at the prompt, and press <Enter> . If you need more 
information, run ipconfig with the /all  option by typing ipconfig /all . 
This shows you all the settings for the Windows NT/2000 computer. Make 
sure you use the settings for the correct Ethernet adapter to configure your 
RT Series PXI controller.

Software Installation
After you assign the IP address of the RT Series PXI controller, you can 
install the LabVIEW RT software on the computer. If your PXI controller 
has LabVIEW RT pre-installed, you do not need to install any additional 
software. The status of your RT Series PXI controller should be Running  
in Remote System Explorer. If your PXI controller has a Windows 
operating system installed, you need to install the LabVIEW RT software. 
In this case, the status of your RT Series PXI controller is No software 

installed . You can install or upgrade the LabVIEW RT software using 
Remote System Explorer.
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To view the software installed on your PXI controller, select Tools»View 
Installed Software to list the software installed on the selected RT Series 
PXI controller. If your PXI controller has LabVIEW RT pre-installed, the 
Currently Installed Software dialog box displays the software and 
version numbers, as shown in Figure 2-6.

Figure 2-6.  Currently Installed Software Dialog Box

If your PXI controller has a Windows operating system installed, the 
Currently Installed Software dialog box will be empty if you are 
installing for the first time. Complete the following steps to install or 
upgrade the LabVIEW RT software on your RT Series PXI controller:

1. Select Programs»National Instruments LabVIEW»Remote 
System Explorer from the Windows Start menu on your host PC to 
run Remote System Explorer.

2. Click the correct PXI system and select Tools»Install/Upgrade 
Software.
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3. The Install/Upgrade Software dialog box, shown in Figure 2-7, 
appears. Click Install  to begin installation of LabVIEW RT files.

Figure 2-7.  Install/Upgrade Software Dialog Box

4. A list of software to be installed appears. Click Proceed.

5. When installation is complete, click Close to exit the Install/Upgrade 
Software dialog box. Click Yes when prompted to reboot the system.

6. After the RT Series PXI controller has rebooted, select View»Refresh 
to view the system configuration. The status should now be Running .

Once you assign the IP address and install the LabVIEW RT software, the 
RT Series PXI Controller is configured for use with LabVIEW RT on the 
host PC. Refer to Chapter 3, LabVIEW RT Programming, for more 
information about targeting the RT Series PXI controller and running 
LabVIEW RT applications.

Locking System Configuration
After you configure the RT Series PXI system, you can lock the system 
configuration with a password to prevent others on your network from 
changing the configuration unless the correct password is provided. In 
addition, a host PC on the network cannot target LabVIEW RT to the RT 
Series PXI system without a password unless the host is in the RT Target: 
Access list. Refer to the RT Target: Access section of Chapter 3, LabVIEW 
RT Programming, for more information about RT Target: Access 
preferences.
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Complete the following steps to lock the system configuration:

1. Click on your PXI system and select Tools»Lock/Unlock System in 
Remote System Explorer. The Locking System Configuration dialog 
box appears.

2. Enter and retype a password. 

3. Click OK  to lock the system configuration.

You must select Tools»Lock/Unlock System in Remote System Explorer 
and enter the correct password to unlock the system configuration.

Remote DAQ Configuration
You must configure any National Instruments PXI DAQ boards before you 
can access them from a LabVIEW RT application targeted to the RT Series 
PXI controller. Use Remote DAQ Configuration to configure PXI DAQ 
boards in your RT Series PXI system. To launch Remote DAQ 
Configuration, select Tools»Configure DAQ Devices in Remote System 
Explorer or select Tools»Remote DAQ Configuration in Measurement & 
Automation Explorer.

Note If you access Remote DAQ Configuration from Measurement & Automation 
Explorer, you must enter the IP address of the RT Series PXI system you configure. 
However, if you access Remote DAQ Configuration from Remote System Explorer, 
Remote DAQ Configuration automatically uses the IP address of the currently selected 
RT Series PXI system.



© National Instruments Corporation 3-1 RT Series PXI/CompactPCI Controller User Manual

3
LabVIEW RT Programming

This chapter contains information about using LabVIEW RT with your 
RT Series PXI controller.

Launching LabVIEW RT and Downloading VIs
In the LabVIEW RT Development System, select Operate»Select 
Execution Target to access the Select Target Platform dialog box, 
shown in Figure 3-1.

Figure 3-1.  Select Target Platform Dialog Box

Use the pull-down menu to select where you want to run VIs. When you 
select a target platform, the RT Development System downloads any VI 
you subsequently run to that target platform. Selecting Host PC 
(LabVIEW for Windows)  makes LabVIEW RT behave like LabVIEW for 
Windows on the host PC.

To target LabVIEW RT to your RT Series PXI controller, select RT Engine 
on Network. Enter the IP address and password specified for the RT Series 
PXI system using Remote System Explorer, then click OK . If no password 
is specified for the RT Series PXI controller, leave this field blank. When 
targeting LabVIEW RT to an RT Series PXI system, the PXI controller 
does not need to reside on the same subnet as the host PC. Enter the 
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IP address of the remote system. To configure PXI systems using Remote 
System Explorer, click Configure.

Note If the IP address of the host PC appears in the RT Target: Access list of the RT 
Series PXI controller, you do not need to enter the password.

Network Preferences
When you target LabVIEW RT to a networked RT Series device, you can 
access LabVIEW preferences from Edit»Preferences. These preferences 
only apply to the LabVIEW RT Development System running on the 
host PC.

In addition to these preference settings, you also can set preferences for the 
RT Engine on the RT Series PXI controller when you target LabVIEW RT 
to the controller. Select Edit»Network Preferences to access these 
preferences. These settings apply to LabVIEW RT applications running on 
the RT Series PXI controller. The Performance and Disk, VI Server, and 
Web Server preference dialog boxes are identical to the normal LabVIEW 
preference dialog boxes. However, the settings are applied to the RT Series 
PXI controller. Refer to the LabVIEW Online Reference or the G 
Programming Reference Manual for more information about Performance 
and Disk, VI Server, and Web Server preference settings.

You also can use two additional, unique groups of preference settings for 
LabVIEW RT applications on networked RT Series devices—RT Target: 
Access and RT Target: Miscellaneous.

RT Target: Access
Use RT Target: Access preferences to limit which hosts can target the 
RT Engine on the PXI controller. Refer to the LabVIEW RT User Manual 
for more information about the RT Engine. If the IP address of your 
host PC matches an entry that allows access, you can target the RT Series 
PXI controller without providing a password, even if the RT Series 
PXI system configuration is locked. If your host IP address matches an 
entry that denies access or does not match any entry, you must provide the 
correct password to target the RT Series PXI controller.



Chapter 3 LabVIEW RT Programming

© National Instruments Corporation 3-3 RT Series PXI/CompactPCI Controller User Manual

When the LabVIEW RT Development System tries to target the RT Engine 
on the PXI controller, the RT Engine compares the host PC IP address to 
the entries in the RT Target: Access list to determine if the host PC is 
permitted access. If an entry in the list matches the host PC address, the 
RT Engine either allows or denies access, based on what you define for 
your entry. If a subsequent entry also matches the host PC address, that 
permission is used in place of the previous permission. For example, in 
Figure 3-2, a.test.site.com  and b.test.site.com  are permitted 
access even though the list indicates, by the * wildcard, that all addresses 
ending in .test.site.com  are not permitted access. If no entry matches 
the host PC address, access is denied unless you supply a password. Refer 
to Table 3-1 for more information about the * wildcard and permitting 
matching access entries.

Figure 3-2.  RT Target: Access Preferences Dialog Box

To specify an Internet host address, enter its domain name or IP address. 
Use the *  wildcard when specifying Internet host addresses. For example, 
you can specify all hosts within the domain site.com  with the entry 
*.site.com . You can specify all hosts in the subnet whose first two 
numbers are 130.164 with the entry 130.164.* . The entry *  matches all 
addresses.



Chapter 3 LabVIEW RT Programming

RT Series PXI/CompactPCI Controller User Manual 3-4 www.ni.com

Table 3-1 shows examples of RT Target: Access list entries.

In Figure 3-2, all hosts in the site.com domain may target the RT Engine, 
with the exception of all hosts in the test.site.com domain. Additionally, the 
hosts a.test.site.com , b.test.site.com , and 130.164.123.123  
also may target the RT Engine. The host public.site.com  does not have 
access, even though it is in the site.com  domain.

The default RT Target: Access settings permit any host machine to target 
the RT Engine on the PXI controller without a password.

Note If the RT Series PXI controller does not have access to a DNS server, do not use 
domain name entries in the RT Target: Access list. Requests to resolve the domain name 
or an IP address fail and slow down the RT Series PXI system. For performance reasons, 
place frequently matched entries toward the bottom of the RT Target: Access list.

Table 3-1.  Example RT Target: Access List Entries

Access String Matches

* All hosts

test.site.com The host whose domain name is 
test.site.com

*.site.com All hosts whose domain names 
end with .site.com

130.164.123.123 The host with the IP address 
130.164.123.123

130.164.123.* All hosts whose IP addresses start 
with 130.164.123



Chapter 3 LabVIEW RT Programming

© National Instruments Corporation 3-5 RT Series PXI/CompactPCI Controller User Manual

RT Target: Miscellaneous
Use RT Target: Miscellaneous preferences, shown in Figure 3-3, to 
launch LabVIEW RT applications on boot up and specify the Downloaded 
VI Path .

Figure 3-3.  RT Target: Miscellaneous Preferences Dialog Box

Use the Application Path and Launch Application at Boot-up settings to 
automatically launch a built LabVIEW RT application when the PXI 
system is booted. The RT Engine launches the built application specified by 
Application Path when you boot the PXI system. The specified path also 
determines the path and application name that appear when you target 
LabVIEW RT to the PXI controller and select Project»Build Application  
to create an executable LabVIEW RT application. Refer to the Creating 
Stand-Alone Executables section later in this chapter for more information 
about creating LabVIEW RT executable applications.

Note By changing the Application Path, you can create multiple LabVIEW RT 
executable applications on the PXI controller. However, only the executable application 
you specify in the Application Path launches on boot-up.

Select Launch Application at Boot-up to launch the application specified 
in Application Path when you boot the PXI system. You must first create 
the application using the Application Builder before you select this 
preference.
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Use Downloaded VI Path to specify the default path for the RT Engine VIs 
downloaded by LabVIEW RT. VIs are stored on the host PC hard drive and 
are opened in the host LabVIEW RT Development System. Therefore, the 
RT Engine does not know the actual path of the downloaded VIs. The RT 
Engine uses the path specified in Downloaded VI Path for operations that 
require the VI path. For example, the file constant Current VI’s Path  
normally returns the path of the VI in which the constant is used. This 
constant may be used in a VI that reads or writes data to a file on the disk. 
When you run this VI in the RT Engine on the PXI controller, Current VI’s 
Path returns the path specified in the Downloaded VI Path preference, 
appended with the name of the VI.

Creating Stand-Alone Executables
You can create LabVIEW RT executable applications that run on the host 
PC by using Application Builder while LabVIEW RT is targeted to the 
host. Refer to the LabVIEW Application Builder Release Notes for more 
information about using Application Builder when you target LabVIEW 
RT to the host PC. In addition, executable LabVIEW RT applications can 
be embedded on the RT Series PXI controller using the Application Builder 
while LabVIEW RT is targeted to the controller.

Command Line Arguments
Use command line arguments for applications built on the host PC to 
disable the Select Target Platform dialog box and explicitly specify a 
target for the application. You can use these parameters in a shortcut 
from your Windows Startup folder to automatically launch RT Engine 
applications and/or host PC applications when you boot your host PC. 

For example, create a shortcut with the following shortcut target: 

c:\mybuiltapp.exe -target 127.127.44.108 –quithost

To disable the Select Target Platform dialog box, specify a target, such 
as the IP address of the RT Series PXI controller, in the command line 
argument of your built executable using -target . For example,

c:\mybuiltapp_rtengine.exe -target 127.127.44.108

or

c:\mybuiltapp_host.exe -target host
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To disconnect the host PC from the RT engine after all VIs are 
downloaded, use -quithost . For example, 

c:\mybuiltapp_rtengine.exe -target 127.127.44.108 

-quithost

Embedded Applications
When you target LabVIEW RT to the RT Series PXI controller, use the 
Application Builder to create a LabVIEW application that is automatically 
embedded on the targeted RT Series PXI controller. Select Launch 
Application at Boot-up in the network preferences to enable the 
RT Engine to start the built application each time you boot the RT Series 
PXI controller. Refer to the Network Preferences section earlier in this 
chapter for more information about these preferences.

The Build Application  dialog box, shown in Figure 3-4, appears when you 
target LabVIEW RT to a PXI controller and select Project»Build 
Application .

Figure 3-4.  Build Application Dialog Box
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The options in the Target tab of the Build Application  dialog box are the 
same as the options when LabVIEW RT is targeted to the host PC, with 
some of the options disabled. The Application Builder determines the 
Application name, Destination directory, and Support file directory from 
the Application Path setting in Network Preferences. You cannot change 
these settings in the Application Builder when you target LabVIEW RT to 
the PXI controller. If you select Small application with external file for 
subVIs, you cannot change the LLB for other files  path because this path 
is determined from the Application Path setting in Network Preferences.

Use the Source Files and VI Settings tabs the same way you do to build a 
LabVIEW executable when LabVIEW RT is targeted to the host PC. Refer 
to the LabVIEW Application Builder Release Notes for more information 
about these tabs. The App Settings and Installer tabs are disabled when 
you target LabVIEW RT to the RT Series PXI controller because these 
settings do not apply to applications embedded on the PXI controller.

Caution Do not add the file serpdrv  to your application in the Source Files tab. The 
serial port driver for LabVIEW RT is installed on the RT Series PXI controller with 
LabVIEW RT. Manually adding serpdrv  to your application adds the Windows driver, 
which is incompatible with the RT Engine on the PXI controller.

Programming LabVIEW RT
Because LabVIEW RT runs on hardware platforms that do not have all the 
components found in a PC, LabVIEW RT lacks some features found in 
LabVIEW for Windows when LabVIEW RT is targeted to RT Series 
hardware. The following LabVIEW functions are not supported in 
LabVIEW RT on the PXI controller:

• ActiveX

• Front panel data logging

• Dialog boxes

• VISA

• Printing

• Programmatic Menus

Note If you attempt to download to and run on your target platform a VI that has any of 
the unsupported functionality listed above, the VI still runs. However, unsupported 
functions do not work and return standard LabVIEW error codes.
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A
Troubleshooting

This appendix describes various troubleshooting techniques for 
LabVIEW RT and your RT Series PXI controller.

Remote System Explorer Cannot Find PXI Controller
Try the following techniques if your PXI controller does not appear in 
Remote System Explorer.

• Ensure that the PXI controller is located on the same subnet of your 
network as the host PC. If you are unsure of your network 
configuration, consult your network administrator for assistance.

• If you do not have a keyboard connected to the PXI controller, check 
the BIOS settings of the controller. The Halt On setting must be set to 
All, But Keyboard  for the PXI controller to boot without a 
keyboard connected. You can find the Halt On setting in the Standard 
CMOS Setup options. Refer to the PXI-8150B Series User Manual for 
more information about BIOS settings.

PXI Controller Boots into Windows When a LabVIEW 
RT Boot Floppy Disk is Used

Check the BIOS setting for the Boot Sequence of the PXI controller. The 
boot sequence for your PXI controller defined in the BIOS settings must be 
set to A,C,...  to boot from a floppy disk. If this BIOS setting is set to boot 
from the C:  drive before the A:  drive, the controller only boots into 
Windows. You can find the Boot Sequence setting in the BIOS Features 
Setup settings. Refer to the PXI-8150B Series User Manual for more 
information about BIOS settings.
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Runaway Startup Application
If a runaway user application has caused the system to become 
unresponsive you must use a PXI Launch Settings Reset Disk to boot the 
PXI controllers into LabVIEW RT without launching the startup 
application. The PXI Launch Settings Reset Disk resets the system so that 
LabVIEW RT does not start any user applications at boot up. No other 
settings are affected. Refer to the Disk Utilities section in Chapter 2, 
Installation and Configuration, for more information about creating a PXI 
Launch Settings Reset Disk.
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B
Technical Support Resources

This appendix describes the comprehensive resources available to you in 
the Technical Support section of the National Instruments Web site and 
provides technical support telephone numbers for you to use if you have 
trouble connecting to our Web site or if you do not have internet access.

NI Web Support
To provide you with immediate answers and solutions 24 hours a day, 
365 days a year, National Instruments maintains extensive online technical 
support resources. They are available to you at no cost, are updated daily, 
and can be found in the Technical Support section of our Web site at 
www.ni.com/support

Online Problem-Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of 

frequently asked questions (FAQs) and their corresponding answers or 
solutions, including special sections devoted to our newest products. 
The database is updated daily in response to new customer experiences 
and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through 
common problems and answer questions about our entire product line. 
Wizards include screen shots that illustrate the steps being described 
and provide detailed information ranging from simple getting started 
instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest 
editions of National Instruments hardware and software product 
manuals.

• Hardware Reference Database—A searchable database containing 
brief hardware descriptions, mechanical drawings, and helpful images 
of jumper settings and connector pinouts.

• Application Notes—A library with more than 100 short papers 
addressing specific topics such as creating and calling DLLs, 
developing your own instrument driver software, and porting 
applications between platforms and operating systems.



Appendix B Technical Support Resources

RT Series PXI/CompactPCI Controller User Manual B-2 www.ni.com

Software-Related Resources
• Instrument Driver Network —A library with hundreds of instrument 

drivers for control of standalone instruments via GPIB, VXI, or serial 
interfaces. You also can submit a request for a particular instrument 
driver if it does not already appear in the library.

• Example Programs Database—A database with numerous, 
non-shipping example programs for National Instruments 
programming environments. You can use them to complement the 
example programs that are already included with National Instruments 
products.

• Software Library —A library with updates and patches to application 
software, links to the latest versions of driver software for National 
Instruments hardware products, and utility routines.

Worldwide Support
National Instruments has offices located around the globe. Many branch 
offices maintain a Web site to provide information on local services. You 
can access these Web sites from www.ni.com/worldwide

If you have trouble connecting to our Web site, please contact your local 
National Instruments office or the source from which you purchased your 
National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For 
telephone support outside the United States, contact your local branch 
office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, 
Brazil 011 284 5011, Canada (Calgary) 403 274 9391, 
Canada (Ontario) 905 785 0085, Canada (Québec) 514 694 8521, 
China 0755 3904939, Denmark 45 76 26 00, Finland 09 725 725 11, 
France 01 48 14 24 24, Germany 089 741 31 30, Greece 30 1 42 96 427, 
Hong Kong 2645 3186, India 91805275406, Israel 03 6120092, 
Italy 02 413091, Japan 03 5472 2970, Korea 02 596 7456, 
Mexico (D.F.) 5 280 7625, Mexico (Monterrey) 8 357 7695, 
Netherlands 0348 433466, New Zealand 09 914 0488, 
Norway 32 27 73 00, Poland 0 22 528 94 06, Portugal 351 1 726 9011, 
Singapore 2265886, Spain 91 640 0085, Sweden 08 587 895 00, 
Switzerland 056 200 51 51, Taiwan 02 2528 7227, 
United Kingdom 01635 523545
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Glossary

Prefix Meanings Value

m- milli- 10–3

k- kilo- 103

M- mega- 106

G- giga- 109

A

address character code that identifies a specific location (or series of locations) 
in memory

amplification a type of signal conditioning that improves accuracy in the resulting 
digitized signal and reduces noise

B

b bit—one binary digit, either 0 or 1

B byte—eight related bits of data, an eight-bit binary number. Also used to 
denote the amount of memory required to store one byte of data.

base address a memory address that serves as the starting address for programmable 
registers. All other addresses are located by adding to the base address.

BIOS basic input/output system—BIOS functions are the fundamental level of 
any PC or compatible computer. BIOS functions embody the basic 
operations needed for successful use of the computer’s hardware resources.

buffer temporary storage for acquired or generated data (software)

bus the group of conductors that interconnect individual circuitry in a computer. 
Typically, a bus is the expansion vehicle to which I/O or other devices are 
connected. Examples of PC buses are the ISA and PCI bus.
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C

channel pin or wire lead to which you apply or from which you read the analog or 
digital signal. Analog signals can be single-ended or differential. For digital 
signals, you group channels to form ports. Ports usually consist of either 
four or eight digital channels.

channel clock the clock controlling the time interval between individual channel sampling 
within a scan. Boards with simultaneous sampling do not have this clock.

clock hardware component that controls timing for reading from or writing to 
groups

CPU central processing unit

D

DAQ data acquisition—(1) collecting and measuring electrical signals from 
sensors, transducers, and test probes or fixtures and inputting them to a 
computer for processing; (2) collecting and measuring the same kinds of 
electrical signals with A/D and/or DIO boards plugged into a computer, and 
possibly generating control signals with D/A and/or DIO boards in the 
same computer

default setting a default parameter value recorded in the driver. In many cases, the default 
input of a control is a certain value (often 0) that means use the current 
default setting. For example, the default input for a parameter may be do 
not change current setting, and the default setting may be no AMUX-64T 
boards. If you do change the value of such a parameter, the new value 
becomes the new setting. You can set default settings for some parameters 
in the configuration utility or manually using switches located on the 
device. 

device a plug-in data acquisition board, card, or pad that can contain multiple 
channels and conversion devices. Plug-in boards, PCMCIA cards, and 
devices such as the DAQPad-1200, which connects to your computer 
parallel port, are all examples of DAQ devices. SCXI modules are distinct 
from devices, with the exception of the SCXI-1200, which is a hybrid.

drivers software that controls a specific hardware device such as a DAQ board or 
a GPIB interface board
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E

event the condition or state of an analog or digital signal

G

GPIB General Purpose Interface bus, synonymous with HP-IB. The standard bus 
used for controlling electronic instruments with a computer. Also called 
IEEE 488 bus because it is defined by ANSI/IEEE Standards 488-1978, 
488.1-1987, and 488.2-1987.

H

handshaked digital I/O a type of digital acquisition/generation where a device or module accepts 
or transfers data after a digital pulse has been received. Also called latched 
digital I/O.

hardware the physical components of a computer system, such as the circuit boards, 
plug-in boards, chassis, enclosures, peripherals, and cables

hardware triggering a form of triggering where you set the start time of an acquisition and gather 
data at a known position in time relative to a trigger signal

I

instrument driver a set of high-level software functions that controls a specific GPIB, VXI, 
or RS-232 programmable instrument or a specific plug-in DAQ board. 
Instrument drivers are available in several forms, ranging from a function 
callable language to a virtual instrument (VI) in LabVIEW.

interrupt a computer signal indicating that the CPU should suspend its current task 
to service a designated activity

interrupt level the relative priority at which a device can interrupt

I/O input/output—the transfer of data to/from a computer system involving 
communications channels, operator interface devices, and/or data 
acquisition and control interfaces
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L

LabVIEW laboratory virtual instrument engineering workbench

LED light-emitting diode

library a file containing compiled object modules, each comprised of one of more 
functions, that can be linked to other object modules that make use of these 
functions. NIDAQMSC.LIB is a library that contains NI-DAQ functions. 
The NI-DAQ function set is broken down into object modules so that only 
the object modules that are relevant to your application are linked in, while 
those object modules that are not relevant are not linked.

M

MIO multifunction I/O

N

NI-DAQ National Instruments driver software for DAQ hardware

O

onboard channels channels provided by the plug-in data acquisition board

onboard RAM optional RAM usually installed into SIMM slots

operating system base-level software that controls a computer, runs programs, interacts with 
users, and communicates with installed hardware or peripheral devices
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P

PCI Peripheral Component Interconnect—a high-performance expansion bus 
architecture originally developed by Intel to replace ISA and EISA. It is 
achieving widespread acceptance as a standard for PCs and work-stations; 
it offers a theoretical maximum transfer rate of 132 Mbytes/s.

PID control a three-term control mechanism combining proportional, integral, and 
derivative control actions. Also see proportional control, integral control, 
and derivative control.

port (1) a communications connection on a computer or a remote controller 
(2) a digital port, consisting of four or eight lines of digital input and/or 
output

protocol the exact sequence of bits, characters, and control codes used to transfer 
data between computers and peripherals through a communications 
channel, such as the GPIB bus

R

RAM random-access memory

real time a property of an event or system in which data is processed as it is acquired 
instead of being accumulated and processed at a later time

resolution the smallest signal increment that can be detected by a measurement 
system. Resolution can be expressed in bits, in proportions, or in percent 
of full scale. For example, a system has 12-bit resolution, one part in 
4,096 resolution, and 0.0244% of full scale.

resource locking a technique whereby a device is signaled not to use its local memory while 
the memory is in use from the bus

S

sensor a device that responds to a physical stimulus (heat, light, sound, pressure, 
motion, flow, and so on), and produces a corresponding electrical signal

shared memory memory that can be sequentially accessed by more than one controller or 
processor but not simultaneously accessed. Also known as dual-mode 
memory.
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signal conditioning the manipulation of signals to prepare them for digitizing

soft reboot restarting a computer without cycling the power, usually via the operating 
system

software trigger a programmed event that triggers an event such as data acquisition

software triggering a method of triggering in which you simulate an analog trigger using 
software. Also called conditional retrieval.

system RAM RAM installed on a personal computer and used by the operating system, 
as contrasted with onboard RAM

T

transfer rate the rate, measured in bytes/s, at which data is moved from source to 
destination after software initialization and set up operations; the maximum 
rate at which the hardware can operate

trigger any event that causes or starts some form of data capture

U

update the output equivalent of a scan. One or more analog or digital output 
samples. Typically, the number of output samples in an update is equal to 
the number of channels in the output group. For example, one pulse from 
the update clock produces one update which sends one new sample to every 
analog output channel in the group. 

update rate the number of output updates per second
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V

VI virtual instrument—(1) a combination of hardware and/or software 
elements, typically used with a PC, that has the functionality of a classic 
stand-alone instrument (2) a LabVIEW software module (VI), which 
consists of a front panel user interface and a block diagram program

VISA virtual instrument software architecture—a new driver software 
architecture developed by National Instruments to unify 
instrumentation softwareGPIB, DAQ, and VXI. It has been accepted as 
a standard for VXI by the VXIplug&play Systems Alliance.

W

waveform multiple voltage readings taken at a specific sampling rate

word the standard number of bits that a processor or memory manipulates at one 
time. Microprocessors typically use 8-, 16-, or 32-bit words.
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Index

B
booting into LabVIEW RT, 2-2 to 2-4

PXI controller with LabVIEW RT 
installed, 2-2

PXI controller with Windows installed, 
2-2 to 2-4

C
CAT-5 crossover cable connection, 2-2
configuration, 2-1 to 2-14

booting into LabVIEW RT, 2-2 to 2-4
PXI controller with LabVIEW RT 

installed, 2-2
PXI controller with Windows installed, 

2-2 to 2-4
locking system configuration, 2-13 to 2-14
network configuration, 2-1 to 2-2

direct CAT-5 crossover cable 
connection, 2-2

PXI controller on network, 2-1 to 2-2
Remote DAQ configuration, 2-14
Remote System Explorer, 2-4 to 2-11

disk utilities, 2-5 to 2-6
Ethernet parameters, 2-9 to 2-10
IP address configuration, 2-7 to 2-9
IP address selection, 2-10 to 2-11
toolbar functions, 2-5

software installation, 2-11 to 2-13
conventions used in manual, vii
creating stand-alone executables, 3-6 to 3-8

command line arguments, 3-6 to 3-7
embedded applications, 3-7 to 3-8

D
DHCP servers, 2-9
diagnostic resources, online, B-1
disk utilities, 2-5 to 2-6

PXI Boot Disk, 2-6
PXI Format Hard Drive Disk, 2-6
PXI IP Settings Reset Disk, 2-6
PXI Launch Settings Reset Disk, 2-6
PXI Uninstall Disk, 2-6

documentation
conventions used in manual, vii
related documentation, viii

downloading VIs, 3-1 to 3-2

E
Ethernet parameters, configuration, 2-9 to 2-10

I
installation

Remote System Explorer, 2-1
software, 2-11 to 2-13

IP address
choosing for networks with and without 

administrator, 2-10 to 2-11
configuration, 2-7 to 2-9

L
LabVIEW RT, 3-1 to 3-8. See also RT Series 

PXI controller.
creating stand-alone executables, 3-6 to 3-8

command line arguments, 3-6 to 3-7
embedded applications, 3-7 to 3-8

downloading VIs, 3-1 to 3-2
installation, 2-11 to 2-13
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launching, 3-1 to 3-2
network preferences, 3-2 to 3-6

RT Target: Access, 3-2 to 3-4
RT Target: Miscellaneous, 3-5 to 3-6

programming considerations, 3-8
Remote System Explorer installation, 2-1
unsupported LabVIEW functions, 3-8

launching LabVIEW RT, 3-1 to 3-2
locking system configuration, 2-13 to 2-14

M
manual. See documentation.

N
National Instruments Web support, B-1 to B-2
network configuration, 2-1 to 2-2

direct CAT-5 crossover cable 
connection, 2-2

PXI controller on network, 2-1 to 2-2
network preferences, 3-2 to 3-6

RT Target: Access, 3-2 to 3-4
RT Target: Miscellaneous, 3-5 to 3-6

NI-DAQ software, 1-2

P
problem-solving and diagnostic resources, 

online, B-1
PXI Boot Disk, 2-6
PXI controller. See RT Series PXI controller.
PXI Format Hard Drive Disk, 2-6
PXI IP Settings Reset Disk, 2-6
PXI Launch Settings Reset Disk, 2-6
PXI Uninstall Disk, 2-6

R
Remote DAQ configuration, 2-14
Remote System Explorer, 2-4 to 2-11

cannot find PXI Controller, A-1
disk utilities, 2-5 to 2-6
Ethernet parameters, 2-9 to 2-10
installation, 2-1
IP address configuration, 2-7 to 2-9
IP address selection, 2-10 to 2-11
toolbar functions, 2-5

requirements for getting started, 1-2
RT Series PXI controller. See also 

configuration; LabVIEW RT.
booting into LabVIEW RT, 2-2 to 2-4
boots into Windows when LabVIEW RT 

boot disk is used, A-1
not found by Remote System 

Explorer, A-1
overview, 1-1
requirements for getting started, 1-2
software programming choices, 1-2

RT Target: Access preferences, 3-2 to 3-4
RT Target: Miscellaneous preferences, 

3-5 to 3-6
runaway startup application, A-2

S
software

installation, 2-11 to 2-13
programming choices, 1-2

software-related resources, B-2
stand-alone executables, creating, 3-6 to 3-8

command line arguments, 3-6 to 3-7
embedded applications, 3-7 to 3-8



Index

© National Instruments Corporation I-3 RT Series PXI/CompactPCI Controller User Manual

T
technical support resources, B-1 to B-2
toolbar functions, Remote System 

Explorer, 2-5
troubleshooting

PXI Controller boots into Windows, A-1
Remote System Explorer cannot find PXI 

controller, A-1
runaway startup application, A-2

V
VIs, downloading, 3-1 to 3-2

W
Web support from National Instruments, 

B-1 to B-2
online problem-solving and diagnostic 

resources, B-1
software-related resources, B-2

Worldwide technical support, B-2
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